python 3.6.1 kræver Windows 7 Service Pack 1 at installere

Indlæg af Hanne Mølgaard Plasc

Problem



Jeg forsøger at installere python 3.6.1 på mine windows 7 32 bit. Men det beder altid om Windows 7 Service Pack 1. Jeg har allerede installeret Windows 7 Service Pack 1 og mine vinduer er opdateret helt. hvad skal jeg gøre?

Bedste reference


Ifølge udgivelsesnoterne kræver det en opdatering til C-runtime-biblioteker. [4]


Ifølge denne note har Python brug for Microsoft C runtime for Visual Studio 2015, især filen ucrtbase.dll. Du kan downloade det her. [5] [6]


For ms-windows brugere vil jeg generelt anbefale at bruge en Python distribution som ActivePython eller Anaconda. De gør livet meget nemmere, hvis du vil bruge kompilerede udvidelsesmoduler som numpy. Ved $WORK bruger jeg Anaconda mig selv. Det kommer med mange ekstra ting som numpy, IPython et cetera. Og det har et pakkehåndteringsværktøj kaldet conda, hvis du vil få ekstra moduler eller opdatere eksisterende. [7] [8]