windows - Sbt Fejl henter nødvendige biblioteker

Indlæg af Hanne Mølgaard Plasc

Problem



Jeg forsøgte at opdatere sbt til 0.13.15, og nu når jeg forsøger at køre sbt får jeg følgende fejl. Jeg er ikke bag nogen proxy og .pom-linket, der er nævnt i fejlnedlæsningen uden problemer i browseren. Før opgradering sbt 0.13.7 fungerede uden problemer for mig. Jeg er på Windows 10.


Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
Getting org.scala-sbt sbt 0.13.15  (this may take some time)...

:: problems summary ::
:::: WARNINGS
    problem while downloading module descriptor: https://repo1.maven.org/maven2/org/scala-sbt/ivy/ivy/2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4/ivy-2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4.pom: Read timed out (19292ms)

            module not found: org.scala-sbt.ivy#ivy;2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4

    ==== local: tried

      C:UsersKamil.ivy2localorg.scala-sbt.ivyivy2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4ivysivy.xml

      -- artifact org.scala-sbt.ivy#ivy;2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4!ivy.jar:

      C:UsersKamil.ivy2localorg.scala-sbt.ivyivy2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4jarsivy.jar

    ==== local-preloaded-ivy: tried

      file:/C:/Users/Kamil/.sbt/preloaded/org.scala-sbt.ivy/ivy/2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4/ivys/ivy.xml

    ==== local-preloaded: tried

      file:/C:/Users/Kamil/.sbt/preloaded/org/scala-sbt/ivy/ivy/2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4/ivy-2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4.pom

      -- artifact org.scala-sbt.ivy#ivy;2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4!ivy.jar:

      file:/C:/Users/Kamil/.sbt/preloaded/org/scala-sbt/ivy/ivy/2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4/ivy-2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4.jar

    ==== Maven Central: tried

      https://repo1.maven.org/maven2/org/scala-sbt/ivy/ivy/2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4/ivy-2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4.pom

    ==== typesafe-ivy-releases: tried

      https://repo.typesafe.com/typesafe/ivy-releases/org.scala-sbt.ivy/ivy/2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4/ivys/ivy.xml

    ==== sbt-ivy-snapshots: tried

      https://repo.scala-sbt.org/scalasbt/ivy-snapshots/org.scala-sbt.ivy/ivy/2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4/ivys/ivy.xml

            ::::::::::::::::::::::::::::::::::::::::::::::

            ::          UNRESOLVED DEPENDENCIES         ::

            ::::::::::::::::::::::::::::::::::::::::::::::

            :: org.scala-sbt.ivy#ivy;2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4: not found

            ::::::::::::::::::::::::::::::::::::::::::::::



:: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS
unresolved dependency: org.scala-sbt.ivy#ivy;2.3.0-sbt-48dd0744422128446aee9ac31aa356ee203cc9f4: not found
Error during sbt execution: Error retrieving required libraries
Error: Could not retrieve sbt 0.13.15

Bedste reference


Du skal kun oprette en .sbt epositories fil, hvis du gør noget særligt (f.eks. Ved at bruge en lokal artefakt server, f.eks. Nexus eller Artifactory ). Måske din installation gik lidt forkert? Prøv at oprette denne fil (C:UsersKamil.sbt epositories) med følgende indhold, og prøv derefter din build igen.


[repositories]
  local
  sbt-releases-repo: http://repo.typesafe.com/typesafe/ivy-releases/, [organization]/[module]/(scala\_[scalaVersion]/)(sbt\_[sbtVersion]/)[revision]/[type]s/[artifact](-[classifier]).[ext]
  sbt-plugins-repo: http://repo.scala-sbt.org/scalasbt/sbt-plugin-releases/, [organization]/[module]/(scala\_[scalaVersion]/)(sbt\_[sbtVersion]/)[revision]/[type]s/[artifact](-[classifier]).[ext]
  maven-central: http://repo1.maven.org/maven2/