asp.net - Fejl ved installation af PHP ved hjælp af Web Platform Installer på Windows 10/IIS 10

Indlæg af Hanne Mølgaard Plasc

Problem



Jeg udvikler en ASP MVC hjemmeside. Jeg har købt et plugin, der bruger PHP-filer, og jeg vil bruge det på mit websted.


Jeg forsøger at installere PHP 7.1.1 på Windows 10, IIS 10, ved hjælp af Web Platform Installer 5.0.


Jeg får en fejl:



  PHP 7.1.1 (x64) Produktet installerede ikke med succes

  
  Windows Cache Extension og PHP manager for IIS mislykkes også, men jeg tror, ​​det er på grund af afhængighed af PHP 7.1.1.



Jeg har allerede prøvet disse:


1) Indstil denne nøgle værdi til 8:


HKEY\_LOCAL\_MACHINE/SYSTEM/CurrentControlSet/Services/W3SVC/Parameters/MajorVersi


2). Net 3.5 installeret og WCF TTP Aktivering er aktiveret for. Net Framework 3.


Hvad er den bedste måde at få PHP-filer til at arbejde på min maskine?

Bedste reference


Jeg endte med at installere PHP manuelt. Webplatformsinstallatøren har mange problemer (i hvert fald med PHP-installation), og manuel installation af PHP er ret simpelt. [4]