windows - Ruby LoadError: kan ikke indlæse sådan fil - tk

Indlæg af Hanne Mølgaard Plasc

Problem



Jeg forsøger at bruge tk i Ruby i Windows 10. Jeg har installeret ActiveTcl og Ruby 2.4 fra https://rubyinstaller.org/downloads/. Jeg får fejl som: [3]


F:/Utilities/Ruby24-x64/lib/ruby/2.4.0/rubygems/core\_ext/kernel\_require.rb:55:in `require': cannot load such file -- tk (LoadError)
    from F:/Utilities/Ruby24-x64/lib/ruby/2.4.0/rubygems/core\_ext/kernel\_require.rb:55:in `require'


Også tjekket det samme fra irb kommandoprompt men fik følgende fejl:


F:/Utilities/Ruby24-x64/lib/ruby/2.4.0/rubygems/core\_ext/kernel\_require.rb:55:in `require': cannot load such file -- tk (LoadError)
    from F:/Utilities/Ruby24-x64/lib/ruby/2.4.0/rubygems/core\_ext/kernel\_require.rb:55:in `require'


Kan du rådgive mig om, hvordan du løser dette problem?

Bedste reference


Dette er løst nu.


Jeg har lige medtaget msys2 mappen i sti og derefter anvendt følgende kommando.


perle installation tk


Dette omfattede perlen.


Så hvad man skal følge er:
1) Installer ActiveTCL
2) Installer ruby ​​installer. Til sidst vil det bede om Msys2 installation. Fortsæt som pr. Menuindstilling.
3) Hold ActiveTcl \ bin, Ruby \ bin og msys2 mappe i sti.
4) Kør kommandoen: gem install tk


Dette løser problemet.


Med venlig hilsen,
Sudeshna Bhattacharya