windows - CNTK FastRCNN Python-version Konflikt

Indlæg af Hanne Mølgaard Plasc

Problem



Jeg har fulgt denne vejledning https://docs.microsoft.com/en-us/cognitive-toolkit/Object-Detection-using-Fast-R-CNN#train-on-pascal-voc at gennemføre hurtig R-CNN med CNTK (uden GPU) i Windows. [7]


Jeg har downloadet og samlet binarierne til Python 3.6 fra https://github.com/MrGF/py-faster-rcnn-windows.
I betragtning af at jeg ville bruge CPU'en, har jeg også fulgt denne vejledning: https://github.com/rbgirshick/py-faster-rcnn/issues/123, fordi jeg havde problemer relateret til CUDA (som jeg ikke har ). [8] [9]


Installationsprocessen gik godt (i hvert fald tænkte jeg det ...).


Nu er jeg fast ved udførelsen af ​​run\_fast\_rcnn.py. Den returnerer denne fejl:


File "c:CNTK-masterExamplesImageDetectionutilsproposal\_helpers.py", line 14, in <module>
from utils.cython\_modules.cython\_bbox import bbox\_overlaps
ImportError: Module use of python36.dll conflicts with this version of Python.


Jeg kan ikke undstand hvad det betyder ..


P. S.
Jeg har 2 version af phyton installeret på min pc: Python2.7 og Python3.6.
For at bruge Python3.6 måtte jeg bruge python3 fra konsollen, så jeg troede, at det måske var årsagen til, at modulet måtte af en eller anden grund kalde Python3.6 (den, jeg plejede at installere CNTK), og hvis det kalder python det havde kaldt Python2.7, så jeg ændrer miljøvariablerne, og nu med python referencen er Python3.6, men intet ændret ...

Bedste reference