Hvordan kan jeg løse pipinstallationscertifikatproblemet på Windows med Python 2.7?

Indlæg af Hanne Mølgaard Plasc

Problem




    Dette spørgsmål har allerede et svar her:

    

            

  •             'pip install' mislykkes for hver pakke (&'Kunde ikke finde en version, der opfylder kravet') [[duplikat]]
                    
                        2 svar
                    

            

  •         

  •             Kan ikke installere Python-pakker [[SSL: TLSV1\_ALERT\_PROTOCOL\_VERSION]]
                    
                        12 svar
                    

            

  •     

Bedste reference


Se denne linje i din fejl: /questions/49748063/pip-install-fails-for-every-package-could-not-find-a-version-that-satisfies /questions/49768770/not-able-to-install-python-packages-ssl-tlsv1-alert-protocol-version


routines:SSL23\_GET\_SERVER\_HELLO:tlsv1 alert protocol version'),)': 


Python.org sites har for nylig stoppet support for TLS v1.0 og v1.1


Prøv at opgradere pip som følger:


curl https://bootstrap.pypa.io/get-pip.py | python


Du kan stadig bruge Python 2.7, når du opgraderer pip, da den derefter bruger den senere TLS-version (dvs.>=1.2)


Se dette svar for flere detaljer.