.net - TLS-version ved hjælp af Internet Explorer

Indlæg af Hanne Mølgaard Plasc

Problem



Jeg har nogle problemer med de sikkerhedsprotokoller, der bruges af en url, og jeg kan lide nogle forslag til, hvad de skal gøre, eller hvor de skal kigge på.


Her er url: https://nfe.sefazrs.rs.gov.br/ws/NfeStatusServico/NfeStatusServico4.asmx[1]


SSL Labs-tests bekræfter, at den understøtter alle TLS-versioner:


TLS-versioner [2]


Internet Explorer bruger den mest sikre version som standard, da alle TLS versioner er aktiveret i Internet Options. I de fleste af de tests, jeg har lavet ved hjælp af forskellige computere, forbinder denne url med TLS 1.2 som forventet ved brug af. NET Framework version 4.7.


Dette virker dog forskelligt med nogle bestemte computere, og jeg er ikke sikker på hvorfor. I disse tilfælde bruges TLS 1.0, selv om alle TLS-versioner er aktiveret på fanen Internetindstillinger. Deaktivering af TLS 1.0 får jeg en 'dåse 't forbinde sikkert til denne side' fejlmeddelelse.


Den samme url fungerer sammen med TLS 1.2 ved hjælp af Google Chrome. Nogle webadresser, som https://www.howsmyssl.com/forbinder med TLS 1.2 med Internet Explorer, så det ser ikke ud som et 'inkompatibilitets' problem. Nogle ideer? [3]

Bedste reference