Windows 10 C # UWP App Icon/Navn Problemer

Indlæg af Hanne Mølgaard Plasc

Problem



Ikon til UWP vises ikke, når du søger efter app i startmenuen [2]


Live Tile viser det forkerte navn og intet ikon [3]


Indstillinger fra Visual Studio Asset Generation [4]


Billede af tekstfeltet 'Short Name' er udfyldt [5]


Jeg har et problem med en C # UWP Windows App Jeg er ved at udvikle ikonet vises ikke på tegnet og også når de søges i Start-menuen




<?xml version="1.0" encoding="utf-8"?>
<Package xmlns="http://schemas.microsoft.com/appx/manifest/foundation/windows10" xmlns:mp="http://schemas.microsoft.com/appx/2014/phone/manifest" xmlns:uap="http://schemas.microsoft.com/appx/manifest/uap/windows10" IgnorableNamespaces="uap mp">
  <Identity Name="a4c700f9-b389-48e0-897f-165ed80428aa" Publisher="CN=*PERSONAL NAME REMOVED*" Version="1.0.10.0" />
  <mp:PhoneIdentity PhoneProductId="a4c800f9-b689-48e0-897f-165eb80428aa" PhonePublisherId="00000000-0000-0000-0000-000000000000" />
  <Properties>
    <DisplayName>*NAME REMOVED* Testing Tool</DisplayName>
    <PublisherDisplayName>*PERSONAL NAME REMOVED*</PublisherDisplayName>
    <Logo>AssetsStoreLogo.png</Logo>
  </Properties>
  <Dependencies>
    <TargetDeviceFamily Name="Windows.Universal" MinVersion="10.0.0.0" MaxVersionTested="10.0.0.0" />
  </Dependencies>
  <Resources>
    <Resource Language="x-generate" />
  </Resources>
  <Applications>
    <Application Id="App" Executable="$targetnametoken$.exe" EntryPoint="*NAME REMOVED*\_Testing\_Tool.App">
      <uap:VisualElements DisplayName="*NAME REMOVED* Testing Tool" Square150x150Logo="AssetsSquare150x150Logo.png" Square44x44Logo="AssetsSquare44x44Logo.png" Description="*NAME REMOVED* Testing Tool" BackgroundColor="transparent">
        <uap:LockScreen Notification="badge" BadgeLogo="AssetsBadgeLogo.png" />
        <uap:DefaultTile Wide310x150Logo="AssetsWide310x150Logo.png" Square310x310Logo="AssetsLargeTile.png" Square71x71Logo="AssetsSmallTile.png" ShortName="*NAME REMOVED* Testing Tool">
          <uap:ShowNameOnTiles>
            <uap:ShowOn Tile="square150x150Logo" />
            <uap:ShowOn Tile="wide310x150Logo" />
            <uap:ShowOn Tile="square310x310Logo" />
          </uap:ShowNameOnTiles>
        </uap:DefaultTile>
        <uap:SplashScreen Image="Assets*NAME REMOVED*\_white\_logo.png" BackgroundColor="#002395" />
        <uap:InitialRotationPreference>
          <uap:Rotation Preference="landscape" />
        </uap:InitialRotationPreference>
      </uap:VisualElements>
    </Application>
  </Applications>
  <Capabilities>
    <DeviceCapability Name="serialCommunication">
      <Device Id="any">
        <Function Type="name:serialPort" />
      </Device>
    </DeviceCapability>
  </Capabilities>
</Package>



Hvis du åbner din Package.appxmanifest og går til Visual Assets, vil du se visningsnavn med afkrydsningsfelter. Tjek den relevante boks ud for dine aktiver
og for ikoner kan du tjekke ikonernes billedstørrelse!


Indtast billedbeskrivelse her [6]


håber det vil hjælpe dig ...

Bedste reference


Havde en chat med en Microsoft-medarbejder online, synes dette at være en mindre kendt fejl, det påvirker kun nogle maskiner med bestemte software-/hardwarekonfigurationer. Efter at have testet mit problem på to andre overflader med samme opsætning, fortsatte problemet, men det blev ved at afprøve på en frisk installation af Windows 10 på en HP-bærbar computer problemet.