python - pip 9.0.1 opgradere bag proxy

Indlæg af Hanne Mølgaard Plasc

Problem



Denne kommando:


pip.exe --proxy=<my proxy> install python\_telegram\_bot-10.1.0-py2.py3-none-any.whl


giver fejl:


Collecting future>=0.16.0 (from python-telegram-bot==10.1.0)
  Could not fetch URL https://pypi.python.org/simple/future/: There was a problem confirming the ssl certificate: [SSL: UNKNOWN\_PROTOCOL] unknown protocol (\_ssl.c:590) - skipping
  Could not find a version that satisfies the requirement future>=0.16.0 (from python-telegram-bot==10.1.0) (from versions: )
No matching distribution found for future>=0.16.0 (from python-telegram-bot==10.1.0)


Jeg fandt ud af at problemet med SSL-certifikat er fordi jeg har version af pip 9.0.1. Så jeg besluttede at opgradere det, efter instruktioner fra pipinstallationsinstruktioner. [5]


Jeg prøvede dette:


python.exe -m pip --proxy=<my proxy> install --trusted-host=pypi.python.org --upgrade pip


Med resultatet:


Could not fetch URL https://pypi.python.org/simple/pip/: There was a problem confirming the ssl certificate: [SSL: UNKNOWN\_PROTOCOL] unknown protocol (\_ssl.c:590) - skipping
Requirement already up-to-date: pip in c:python27libsite-packages
You are using pip version 9.0.1, however version 10.0.1 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' command.


Hvilket antyder mig at bruge den nøjagtige kommando, der fører til problemet.


Er der en måde at løse det på en eller anden måde?

Bedste reference