Node.js installationen fejler på Windows 10 1803

Indlæg af Hanne Mølgaard Plasc

Problem



Jeg sluttede min pc i dag, og jeg ønskede at installere node.js på den.
Men for nogle underlige grunde siger det 'Kopiering af filer' og derefter efter et par sekunder står det 'Rolling back'. Jeg kan ikke tænke på en grund til, at den ikke installeres. Windows er Windows 10 'Spring Update' 1803.


https://youtu.be/-OXGGWC41vE[1]


Her er et bevis i form af en unoteret video på Youtube.


Tak på forhånd.


Niklas

Bedste reference


Et batch script (inden////nodejs/node\_modules/npm) understøttes ikke længere på Windows 10, version 1803. Denne fil kopieres ikke korrekt over (dette er IKKE et harddiskproblem, men et problem med denne version af Windows 10!) .


Berørt fil (er):



  • \ nodejs \ node\_modules \ npm \ make.bat (Denne fil alene kræver en genstart.)



Kopiering af denne fil over fra Ziparkivet er mulig, men kræver en genstart for at komme ud af kopieringsprompten.

Andre referencer 1


Det samme problem her, men efter nogle undersøgelser af det gamle samme problem, blev det fundet at installere uden ETW (Event Tracking) eller uden Performance Counters (under installationen kan du vælge disse muligheder under Node.js runtime branch) men jeg fik nogle nye fejl når npm installere/npm køre dev, nogle med node-sass problemer.


EDIT: Ok, så mit problem var direkte med mit antivirusprogram (Avast), jeg har læst, at med AVG er der det samme problem, så kan du installere det uden at slippe af med ETW eller pc.

Andre referencer 2


Jeg stod over for samme problemer i win 10-systemet, men jeg kunne installere det ved at gøre følgende trin:


--- Deaktiver dit antivirusprogram, det kan være blokering af nodehændelsesspor


--- Deaktiver installation af alle komponenter som vist i billedet nedenfor


installationsfil billede [2]


- Afslut installationen


- Efter installationen igen gå til opsætning og aktiver komponenter en efter en og installer, forlade funktionstælleren


- Efter alle komponenter er installeret kode til cmd og gør node -v du vil se det virker