python - Fejl ved installation af Py3ODE (Win10)

Indlæg af Hanne Mølgaard Plasc

Problem



Forsøger at installere Py3ODE under Windows 10 (x64) Jeg fortsætter med at få den samme fejl:


PS C:Users...> pip install py3ode
Collecting py3ode
  Using cached https://files.pythonhosted.org/packages/32/cd/a35273b5edc010d43bb8ec0501d02213daa6ed7f559815c2cbdd7c32091b/Py3ODE-1.2.0.dev9.tar.gz
    Complete output from command python setup.py egg\_info:
    'ode-config' is not recognized as an internal or external command,
    operable program or batch file.
    'ode-config' is not recognized as an internal or external command,
    operable program or batch file.
    WARNING: <ode/ode.h> not found. Downloading and installing it now to your home directory.
    If it's already installed you may have to adjust INC\_DIRS in setup.py.
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "C:Users...AppDataLocalTemppip-install-y4lgahnypy3odesetup.py", line 142, in <module>
        install\_ode()
      File "C:Users...AppDataLocalTemppip-install-y4lgahnypy3odesetup.py", line 125, in install\_ode
        subprocess.check\_call(['./install\_ode.sh', install\_dir])
      File "c:users...appdatalocalprogramspythonpython36-32libsubprocess.py", line 286, in check\_call
        retcode = call(*popenargs, **kwargs)
      File "c:users...appdatalocalprogramspythonpython36-32libsubprocess.py", line 267, in call
        with Popen(*popenargs, **kwargs) as p:
      File "c:users...appdatalocalprogramspythonpython36-32libsubprocess.py", line 709, in \_\_init\_\_
        restore\_signals, start\_new\_session)
      File "c:users...appdatalocalprogramspythonpython36-32libsubprocess.py", line 997, in \_execute\_child
        startupinfo)
    OSError: [WinError 193] \%1 is not a valid Win32 application


Jeg kan ikke give mening ud af fejlmeddelelsen, forstår ikke engang hvorfor der er en Win32-applikation i første omgang.

Bedste reference


Jeg backtracked problemet og det er jo en fejl i pip 10:



  • https://github.com/pyenv/pyenv/issues/1141



Jeg besluttede at nedgradere pip og problemet er væk. [4]