python - tensor flow gpu undlader at installere

Indlæg af Hanne Mølgaard Plasc

Problem



Jeg bruger Python 3.7, og det ser ud til, at hver løsning, jeg søgte, er på Conda-miljø, hvilket jeg ikke bruger.
Min computer spec er intel i7 med nvidia gtx1050, og da jeg brugte kommandoen 'pip3 installer --upgrade tensorflow-gpu' i kommandolinjen, brænder den altid denne fejl.


    C:WINDOWSsystem32>pip3 install --upgrade tensorflow-gpu
Collecting tensorflow-gpu
  Could not find a version that satisfies the requirement tensorflow-gpu (from versions: )
No matching distribution found for tensorflow-gpu


Enhver kan hjælpe? Jeg har CUDA Toolkit 9.2 installeret, og den nyeste cuDNN installeret. Jeg kører Windows 10.

Bedste reference


Når jeg søger 'TensorFlow' i https://pypi.org/project/tensorflow/#files
Jeg finder følgende oplysninger: [2]



  tensorflow-1.8.0-cp36-cp36m-win\_amd64.whl Hjul cp36 28. april 2018



Indtil 2018-07-09 kunne kun python (<=3.6) finde en version, der opfylder kravet tensorflow.


Jeg tror, ​​at hvis du vil bruge TensorFlow, må du måske sænke Python-versionen.


Jeg fandt en version, der opfylder kravet tensorflow.
Og jeg skriver ned metoden i det andet svar på denne side.

Andre referencer 1


2018/07/30
Jeg fandt tensorflow-1.9 for Python3.7 (tensorflow-1.9.0-cp37-cp37m-win\_amd64.whl)


https://www.lfd.uci.edu/~gohlke/pythonlibs/[3]


https://www.lfd.uci.edu/~gohlke/pythonlibs/#tensorflow[4]


Du finder dette på hjemmesiden:



  TensorFlow, beregning ved hjælp af dataflytediagrammer til skalerbar maskinindlæring.
  Kræver numpy + mkl og protobuf. CUDA builds kræver CUDA 9.2 og CUDNN 9.2 .
  tensorflow-1.9.0-cp36-cp36m-win\_amd64.whl
  tensorflow-1.9.0-cp37-cp37m-win\_amd64.whl






anden version af TensorFlow.whl


https://github.com/fo40225/tensorflow-windows-wheel[5]

Andre referencer 2


Tensorflow er kun support på Python 3.5.X versioner. Prøv at installere på nogen af ​​disse versioner. Dette bør løse problemet.

Andre referencer 3


På samme måde som Tensorflow GPU WONT WORK med CUDA toolkit v9.2, skal du downloade og installere v9.0. Den er tilgængelig ved at klikke på 'gamle downloads' på Cuda download siden. TF leder efter en bestemt fil (cudart64\_90.dll), der er fra 9.0 og vil ikke acceptere den tilsvarende version af biblioteket (cudart64\_92.dll) fra den seneste 9.2 version. Den gode nyhed er, at du IKKE skal afinstallere v9.2 af værktøjskassen, Nvidia installatøren vil blot tilføje en separat v9.0-mappe i Nvidia Cuda-biblioteket lige ved siden af ​​den v9.2-mappe, du allerede har. Jeg håber det hjælper.