rubin af støtte i vim på windows

Indlæg af Hanne Mølgaard Plasc

Problem



Jeg er ny til vim og vil gerne konfigurere command-t plugin til at arbejde i vim 7.3. Det siger, at det ikke har rubin support. Er der nogen måde at konfigurere vim til at have ruby ​​support på Windows 7?

Bedste reference


Jeg tror, ​​du skal kompilere vim med --enable-rubyinterp flag.

Kontroller, om vim har støtte til rubin ved hjælp af :version i vi.


Hvis det viser -ruby (ingen rubinunderstøttelse) skal du compilere fra vim-kilde eller hente et installatør, der blev udarbejdet på den måde.

Andre referencer 1


Jeg gætter på, at dit problem er, at du ikke har ruby ​​installeret, og at plug-in har brug for det. Prøv at installere rubin:


http://rubyinstaller.org/[5]

Andre referencer 2


Du kan ikke konfigurere vim til at have rubin-support (som i kontrol af en boks eller ændre en mulighed). Du skal downloade en distribution af vim med ruby-support eller downloade kilderne og kompilere det selv.


vim --version


Hvis det står '-ruby' så skal du installere en anden vim-version, der understøtter den (+ rubin).


Du kan følge trin for trin her: Mit eget indlæg eller Officiel dokinstallation [6] [7]