rubin - installerer mysql som en perle

Indlæg af Hanne Mølgaard Plasc

Problem



Jeg vil udvikle skinner 3 apps ved hjælp af mysql på windows 7 (64 bit) og jeg har installeret mysql via msi download fra mysql site.


mit spørgsmål er, at skal jeg stadig installere mysql-perlen?


tak

Bedste reference


Mysql perle giver rubin bindinger, så ja, du skal installere dette.


Med Rails 3 skal du bruge mysql2 perlen i stedet for mysql perlen.

Andre referencer 1


Her er en ordentlig løsning for alle interesserede, der gør ikke noget ved din nuværende installation af mysql-serveren



  1. Download en zip-fil med mysql server 5.1 IKKE den msi one. Sørg for, at det er 32-bit IKKE 64-bit. (Herfra)

  2. Da der ikke er en installationsfil med dette, skal du oprette en mappe c: \ mysql-gem-install - du kan fjerne den, når du er færdig.

  3. Udpak alle filer fra zip-filen til den mappe, du lige har oprettet.

  4. Kør nu denne kommando [1]


    gem installation mysql2 - '- med-mysql-lib =' c: \ mysql-gem-install \ lib \ opt '- med-mysql-include =' c: \ mysql-gem-install \



Jeg har lige installeret mysql2 perle v. 0.3.7

Andre referencer 2


Jo du gør. Mysql-perlen er en ruby-driver (interface) for at oprette forbindelse til mysql-databasen.


Du skal bruge mysql2 perle i stedet med Rails3. [2]