php - hvilken binær til php5.3 at downloade?

Indlæg af Hanne Mølgaard Plasc

Problem



Henvisning til nedenstående link


http://www.php.net/manual/en/mongo.installation.php#mongo.installation.windows[2]


Der er trådsikker, ikke-tråd sikker og med denne er den også præfikset med VC6, VC8, VC9.


Jeg har vindue 7 Ent og jeg kan ikke forstå hvilket binært (.dll) jeg burde downloade herfra.


Hvordan formoder jeg, hvilken dll jeg skal downloade?


Sådan identificeres hvilken VC compiler + tråd sikker eller ikke-tråd sikker kombination at vælge?.

Bedste reference


For at se, hvilken PHP-installation du har fra kommandolinjen, kør denne kommando:


php -i | more


Dette vil dumpe phpinfo side for side. På den anden side skal du se en 'Zend Extension Build' og/eller en 'PHP Extension Build' -tast under 'System' sektionen. Måske vil det vise noget som 'API ###, TS, VC9'. TS står for 'tråd sikker' (som faktisk også viser som aktiveret/deaktiveret i 'Tråd sikkerhed' nøglen bare lidt under det). 'VC9' står for ... VC9. Du ved allerede, at du har PHP5.3 installeret. Dette betyder at du vil installere PHP5.3 Threadsafe VC9 versionen af ​​Mongo.


Dette er også et eksempel på, hvornår brugeren har givet kommentarer i PHP-håndbogen, er meget hjælpsomme. Tjek den første kommentar af Andrey 01-Jun-2011 11:54.

Andre referencer 1


På http://windows.php.net/download/er der en 'Hvilken version vælger jeg?' Sektion til venstre. [3]



  Hvilken version vælger jeg?

  
  Hvis du er
  ved hjælp af PHP med Apache 1 eller Apache2
  fra apache.org skal du bruge
  VC6 versioner af PHP

  
  Hvis du bruger PHP med IIS dig
  skal bruge VC9 versioner af PHP

  
  VC6 versioner er kompileret med
  ældre Visual Studio 6 compiler

  
  VC9 versioner er kompileret med
  Visual Studio 2008 kompilator og har
  forbedringer i ydeevne og
  stabilitet. VC9-versionerne kræver
  Du skal have Microsoft 2008 C ++
  Runtime (x86) eller Microsoft 2008
  C ++ Runtime (x64) installeret

  
  Brug IKKE VC9 version med apache.org
  binære filer

  
  VC9 versioner af Apache kan hentes
  på Apache Lounge. Vi bruger deres
  binære filer til at opbygge Apache SAPI'erne.


Andre referencer 2


Da du kører Windows 7, ville det være ideelt at downloade VC9.


Hvis din app skal være tråd sikker, skal du downloade Tråd sikker en. Hvis du ikke er sikker på, om din ansøgning skal være Thread Safe, har du sikkert ikke brug for Thread Safe Version alligevel.