windows - Problemer med forbindelse til SVN repository

Indlæg af Hanne Mølgaard Plasc

Problem



Okay. Bare på udkig efter nogle råd om, hvordan man fejler et problem med at forbinde en maskine til et SVN-lager.


Her er detaljerne:
(1) To af vores maskiner forbinder succesfuldt til SVN-depotet, men en maskine gør det ikke.
(2) Vi bruger alle Windows XP og bruger TortoiseSVN-klienten.
(3) Vi var alle i stand til at oprette forbindelse fra vores egne maskiner, men da vi forsøgte en tredje maskine på flere forskellige tidspunkter over flere forskellige dage, ville denne maskine bare ikke forbinde.

(4) Vi kunne SSH via Putty ind i maskinen, men SVN via Tortoise ville bare ikke forbinde.


Hvilke skridt skal jeg tage for at prøve at fejle dette forbindelsesproblem?


Tak for enhver indsigt og feedback.

Bedste reference


Tilsyneladende var dette et fælles nok problem at være på TortoiseSVN FAQ. Her er hvad vi fandt:


SVN + SSH: Forbindelse lukket uventet


Det er blevet rapporteret, at svn + ssh-forbindelser af formen svn + ssh://username@server.com, som tidligere var aktive, stop med at arbejde med TortoiseSVN 1.5. Dette ser ud til at være relateret til plink, og opstår, hvis du har et standard værtsnavn angivet i PuTTY.


Hvis dette er tilfældet, kan du rette det ved at bruge regedit eller regedt32 for at slette HKEY\_CURRENT\_USER/Software/SimonTatham/Putty/Sessions/Default\% 20Settings/HostName.

Andre referencer 1


Kommenterer mesglinjen i din .bashrc fungerede for mig, så noget som:


# mesg n